CentOS 5.1.x PHP 5.3 5.6에 PHP를 업그레이드

가장 CMS등 사이트 의 최신 버전으로 설치하기위한 최소 요구 사항을 가지고 5.1.x pe . 아래의 튜토리얼은 당신에게 당신이 할 수있는 몇 가지 간단한 단계가 표시됩니다 PHP 5.1 5.3.x에 PHP 버전을 업그레이드 pe   5.6.

1. 먼저 중지해야합니다 웹 서버. (httpd 서비스)

서비스 아파치 정지

2. 분명 5.1.x PHP 패키지가 서버에 설치되어 있어야합니다.

yum을 제거 PHP는 PHP-*

3. 당신이 PHP 패키지가 서버에서 삭제됩니다 확인을받은 후, 패키지를 설치로 이동 PHP 5.3.

냠 설치 php53.i386      
냠 설치 - bcmath.i53 php386
냠 설치 php53-cli.i386  
냠 설치 php53-common.i386 
냠 설치 php53-dba.i386  
냠 설치 - devel.i53 php386
yum install php53-gd.i386   
냠 설치 - imap.i53 php386
냠 설치 php53-intl.i386 
냠 설치 php53-ldap.i386 
냠 설치 - mbstring.i53 php386
냠 설치 - mysql.i53 php386
냠 설치 php53-odbc.i386 
냠 설치 php53-pdo.i386  
냠 설치 - pgsql.i53 php386
냠 설치 - process.i53 php386
냠 설치 - pspell.i53 php386
냠 설치 php53 - snmp.i386 
냠 설치 - soap.i53 php386
냠 설치 - xml.i53 php386
냠 설치 - xmlrpc.i53 php386

아니면 더 간단하게, 모든 패키지 php53의 *를 설치.

php53의 설치 *

4. 아파치 웹 서버를 시작합니다

서비스 아파치 시작

패키지 php53 - 배, php53-mcrypt, php53 - Mhash, php53-ODP, php53-pecl-APC si php53-pecl-memcache CentOS 5.6 사용할 수 없습니다.

마지막으로 확인 PHP5.3 버전이 성공적으로 설치되었습니다. . 만들기 PHP는 (예를 들어 info.php). 수있는 :

<?php

phpinfo에서 ();

phpinfo에서 (INFO_MODULES)

?>

파이어 폭스의 주소로 서버 및 액세스 파일에 올라 , 또는 다른 웹 브라우저. 결과는해야한다 :

PHP 정보

당신은 서버 및 명령 줄에 설치되어있는 PHP의 버전을 볼 수 있습니다 : PHP-V 또는 "YUM 목록은 설치 | GREP PHP"(설치된 모든 PHP 패키지를 표시합니다).

PHP를 설치 YUM 목록

- CentOS 5.3 5.6에 설치 / 업그레이드 PHP.

CentOS 5.1.x PHP 5.3 5.6에 PHP를 업그레이드

저자에 관하여

스텔스 LP

설립자와 편집자 스텔스 Settings2006 날짜합니다.
Linux 운영 체제 (특히 CentOS), Mac OS X, Windows XP> Windows 10 및 WordPress (CMS).

코멘트를 남겨