WordPress 5.0 +에서 구텐버그 사용 및 클래식 편집기 사용 안 함

구텐베르크를 사용 중지하고 고전적인 WordPress 게시자로 돌아가시겠습니까?
구텐베르크
는 고전 편집기를 대체하기 위해 최근 WordPress에서 도입 된 편집 도구입니다. 더 역동적이고 이론적으로 더 직관적 인 인터페이스를 가지고 있지만 많은 출판사는 WordPress의 고전적인 발행인보다 사용하기가 더 어렵습니다. 또한 새로운 구텐베버 편집기를 듣기 위해 업데이트되지 않은 오래된 WordPress 테마를 사용하면 모든 종류의 오류가 발생할 가능성이 큽니다. 우리의 경우 WordPress 5.0의 Gutenberg 편집자는 정말 귀찮은 사람이었습니다. 초안을 편집하는 것은 사실상 불가능했습니다. 텍스트를 완전히 선택할 수 없으며 단락의 페이지 정렬이 커서를 놓고 다른 곳에서 글쓰기를 시작했습니다. 이상한.
우리의 선택 의지에서 사이트를 작성하는 사람들은 간단하고 직관적이며 편리한 옵션이 필요합니다. 구텐베르그는 지금까지 우리에게 이런 누출을 보여주지 못했습니다. 아마도 12이 고전으로 편집 한 것보다 더 나은 것, 변화의 영향이 될 수 있습니다.

우리는 혼자가 아닙니다. WordPress의 공식 플랫폼에서 플러그인을 다운로드하면 구텐베르그 (Gutenberg)를 신속하게 비활성화하는 데 도움이되는 플러그인에 대해 높이 평가합니다. 워드 프레스 5.0 부정적인 리뷰가 많습니다. 부정적인 점수를 준 사람들의 대부분은 워드 프레스 테마 Gutenberg와 동적 인 라이브 인터페이스가 준비되지 않은 사용자.

이 기사에서는 WordPress에서 구텐베르크를 어떻게 비활성화시킬 수 있습니까? 현재 테마의 5 고전적인 편집 / 출판 편집부로 돌아 가기.

우선, 파일 편집 권한이 충분해야합니다. functions.php 현재 테마 (활성) 또는 편집 권한이있는 FTP 액세스.

열린 functions.php 행을 추가하십시오.

add_filter('use_block_editor_for_post', '__return_false');

파일을 저장 한 다음 "게시물"→"새로운 추가". 편집기를 보게 될 것입니다. 구텐베르크 그는 사라지고 고전적인 것으로 잘못 인도되었다.
가장 간단한 방법이며 WordPress Plugin을 설치할 필요가 없습니다. WordPress 5.0에서 성공적으로 테스트되었습니다. 이후 버전의 WordPress에서 변경 될 경우이 문서의 업데이트와 함께 사용 중지 방법을 보여줍니다. 구텐베르크.

이전 버전의 5.0 WordPress를 사용하는 경우 functions.php에 다음 줄을 추가하십시오.

add_filter('gutenberg_can_edit_post', '__return_false', 5);

자동 (WordPress 개발자)은 현재 플러그인을 권장하지만 2021까지만 클래식 편집기를 사용할 수 있다고합니다. 그 순간 이후에 우리는 WordPress에서 클래식 에디터를 어떻게 유지할 수 있는지 알게 될 것입니다. 그때까지 구텐 부르크가 더 "친근해질"수있는 옵션도 있습니다.

WordPress 5.0 +에서 구텐버그 사용 및 클래식 편집기 사용 안 함

저자에 관하여

스텔스

가젯과 IT를 의미하는 모든 것에 열정을 갖고 2006의 stealthsettings.com에 기뻐하며 컴퓨터와 macOS, Linux 운영 체제, Windows, iOS 및 Android.

코멘트를 남겨